Basic lab to understand the fundamental concept of MPLS.
IOS: c3660-jk9o3s-mz.124-17.bin
Topology:
First configure EIGRP AS 100 on R1, R2 and R3
R1:
R1#configure terminal
R1(config)#interface f0/1
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router eigrp 100
R1(config-router)#network 192.168.12.0 0.0.0.255
R1(config)#interface f0/1
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#router eigrp 100
R1(config-router)#network 192.168.12.0 0.0.0.255
R2:
R2#configure terminal
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface f0/1
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router eigrp 100
R2(config-router)#network 192.168.12.0 0.0.0.255
R2(config-router)#network 192.168.23.0 0.0.0.255
R2(config)#interface f0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface f0/1
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#router eigrp 100
R2(config-router)#network 192.168.12.0 0.0.0.255
R2(config-router)#network 192.168.23.0 0.0.0.255
R3:
R3#configure terminal
R3(config)#interface f0/0
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router eigrp 100
R3(config-router)#network 192.168.23.0 0.0.0.255
R3(config)#interface f0/0
R3(config-if)#ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#router eigrp 100
R3(config-router)#network 192.168.23.0 0.0.0.255
Now check these 3 routers with the show ip route command, we can see all the routers learned all the routes in EIGRP AS 100.
R1 Initial Configuration
R2 Initial Configuration
R3 Initial Configuration
We can also check the EIGRP neighbor status with the show ip eigrp neighbors command. For example on R1 we have
of course if everything is correct we can ping from R1 to R3
To run MPLS, each router must turn on cef with the “ip cef” command
On R1, R2, R3
R1/R2/R3(config)#ip cef
Now we need to enable MPLS on each interface
R1:
R1(config)#interface f0/1
R1(config-if)#mpls ip
R1(config)#interface f0/1
R1(config-if)#mpls ip
R2:
R2(config)#interface f0/0
R2(config-if)#mpls ip
R2(config)#interface f0/1
R2(config-if)#mpls ip
R2(config)#interface f0/0
R2(config-if)#mpls ip
R2(config)#interface f0/1
R2(config-if)#mpls ip
R3:
R3(config)#interface f0/0
R3(config-if)#mpls ip
R3(config)#interface f0/0
R3(config-if)#mpls ip
A message appears when we enable MPLS (default LDP will be used). For example, after enabling “ip cef” and “mpls ip” on R1:
Now use the show mpls interfaces we can see which interfaces are running MPLS
R1
R2
R3
Check the neighbor’s relationship of these routers with the show mpls ldp neighbor command
R1
R2
R3
TDP has been the default label distribution protocol. Starting in Cisco IOS Release 12.4(3), the default MPLS label distribution protocol is LDP. If you want to run Tag Distribution Protocol (TDP), you can enable TDP on all interfaces by the command “mpls label protocol tdp in global configuration mode
R(config)#mpls label protocol tdp
Or enable TDP on a specific interface
R(config-if)#mpls label protocol tdp
Note: The TDP/LDP configuration in interface mode overwrites the configuration in global configuration mode.
Note: The TDP/LDP configuration in interface mode overwrites the configuration in global configuration mode.
No comments:
Post a Comment